oStorybook

[en]  Accueil  En cours  Nouvelles  Liens  Aide
Aide - Sujet n°106

Sujet n°106 [Libraries] Not very clean...
    - par bodiccea le 21/01/2017 12:00

Hi again,

In developers page, both links to libraries and languages are broken (404).

Beside that, I disagree developers have to download libraries that way, to build the project. We should add dependencies, and ways to build the whole from sources only.

To come back to Android: standard database library in operating system is sqlite (as well as on iOS).
As soon as I can compile on command-line (instructions are not given in Developers' section), I will have a look on this DB issue (I just hope specific DB access is not embedded everywhere in the code, this could be difficult smile
If pure sql statements are made, in a single place, it could be easy to become DB-independant.

br.

Réponse n° 1
    - par favdb le 21/01/2017 19:56

Link to libs : updated (it was correct in the French page).

Link to language dicts : removed, no more necessary.

Separated libs was a logical choice, they don't change every day.

Database : I have no answer.

Réponse n° 2
    - par bodiccea le 22/01/2017 01:05

Thanks for corrections.

My point about libraries is that the page audience are developers. This means that they should be able to build everything (including the libraries zip file).

This does not mean the zip file should not be provided, but this is not sufficient (after all, at least one developer has built the zip file, right ?).

Réponse n° 3
    - par jrebillat le 22/01/2017 10:57

In fact, I disagree.Yes, there is no need to build the libraries, as they are public-domain (in fact open-source) and available on the web. And yes, having to import the zips is not the correct answer, that's sure, but, as it is partially done today, having to build all from sources is a terrible answer !I think that the solution is using maven or graddle (maven, obviously, as most libraries are old ones and graddle is too new to know them) and we have already been discussing of this before.But this is quite a challenge to get rid off all zips and replace them with the correct maven dependencies...It is a decision to take : shall we use maven ? I am ready to work on this point if every body aggrees.

Réponse n° 4
    - par bodiccea le 22/01/2017 11:24

They are public domain, but we need, as developers, to be able to build the libs.zip file.

The discrepancy I found between developers page and git repository is a clear example  of issue we can run into (we could build/package the full software with different libs).

In fact I don't disagree to get a zip file (given it includes all licences text for all of them, I did not check them at all), given I can also get a doc to build it myself, with instructions/how-to smile

Maven is a solution, not the only one : A simple doc for those into full rebuild could be enough (or a download script with a correct build-libs.xml).

This is not a priority, however. Just to keep in mind.

Retour à la liste des sujets
Haut

freeguppy.org © 2004-2015 En savoir plus ... Valid CSS 3