You are here :   Home » Forum » General discussion » Misc minor bugs
 
Cleaning up the forum

All posts prior to 9/19/2016 have been deleted.

Forum - General discussion - Misc minor bugs

Count of members 265 members
Connected : (nobody)
Snif !!!
 

Forum - Forum
General discussion - General discussion

active  Topic # 248

02/10/2022 05:02
by donedwards2

donedwards2



Linux Mint 20, oStorybook 5.05.08
1) When a new project is created, the user probably wants to immediately open it. This doesn't automatically happen.
2) File/Properties doesn't do anything.

3) Help/Bugs bad URL, gets a 404 error (and the website's custom error page is missing too)

4) Export a project in database format, then try to import it into a new project. I've tried with a couple different projects and get errors.

5) File/Export/Book asks for a folder to put the output file in. File/Export/Other Format does likewise. File/Export/Database does not. Instead it uses the last location used for either of the others, whether in this session or previously. (Should test whether it's project-specific.) And if you've never used one of the others, it defaults to the path and filename, minus suffix, of the current project file - if there's no such folder, it gives an error message.

6) The default column width for all displays of lists allows for one narrow character and an ellipsis per column. If the first character of the column name or value isn't narrow, then just the ellipsis. A bit wider would be better.
7) The dropdown for columns to show on Characters list shows an Attributes column. Turning it on does not add it to the table. Nor is there such a field on the Character-editing form.

8) Same for Icon File on Genders list. However, on the Gender-editing form there is a field to put in a path and filename for an icon file. The default file type for this icon file is "oStorybook file". It should be .png. Specifying a file that isn't a .png file - even one that doesn't exist - results in no icon. (Which is useful for getting rid of these icons, but unfortunately that field appears only on the form for Genders. Not on Parts, Characters, Items, or Locations - all of which have default icons.)
9) The Scenes list, Characters column insists on showing an icon and an ellipsis if there is more than one character linked to the scene. If there is only one character, but that character has a name longer than 1 character, the column shows an icon and the first 2-3 characters of the name. This behavior persists even when the column is made extremely wide.

9.1) The Scenes list, Locations column properly handles a single location with a long name, but has the same problem as the Characters column if a scene has more than one location.

9.2) I'm kind of suspicious of the Items column too, but I'm not using Items at present.
Post an answer Top  

Answer n° 1
--------
02/10/2022 10:24
by favdb

favdb



Great, thank you for all these comments. Would you like to join the small development team? Most of the participants are not programmers, just users who have suggestions for improvements? Our exchanges are in French, but using Deepl.com I think you won't have any problem.
Post an answer Top  
Answer n° 2
--------
02/10/2022 20:36
by donedwards2

donedwards2



Sure, I'll join in. I was a professional programmer, retired in 2010 so my skills probably are a bit rusty (and my French far more so, as I haven't used it to speak of since high school). I never worked specifically in Java, but I am - or at least was - fluent in SQL
Post an answer Top  
Answer n° 3
--------
03/10/2022 00:39
by donedwards2

donedwards2



Testing log - original intent was to see if there's an obvious problem with export/import
Created new project, filename Test1.osbk according to the screen that created it, a long novel with 2 parts and 2 chapters.
Tried to open it. Found Test1.mv.db. Which had no parts and no chapters. Also no genders, categories, or strands. In former versions some defaults for these were provided automatically.

Created a part, "part a", part number 1. No problem. If the supposedly-created parts existed, I would have expected a collision on the part number.
Created a chapter, "chapter a", within "part a", ditto.
Could not create a scene.
Created a location.

Could not create a character until after I created a gender and a category. ("gender a" and "category a", then "character a", of course)

Created a strand, then could create a scene.
(Being extremely familiar with database design, I understand these requirements once I found them. However, I shouldn't have had to guess or hunt for them. Being told why something doesn't work is helpful. Clicking a button and having absolutely nothing happen, usually isn't.)

Saved it. After save, filename was changed to "Test1.osbk".
Exported it in database format.
Closed & restarted the program. Created new project, "Test2.osbk" which of course was named "Test2.mv.db"
Tried to import the database.xml file from "Test1". Set up no problem, but clicking the "Import" button simply caused the button to be highlighted. Doesn't matter whether the "Replace all existing" checkbox is marked or not. It doesn't lock up though - the "Cancel" button works.
Manually examined the database.xml file. Nothing obviously wrong with it. Parts are in order consistent with the above-discovered requirements.
Renamed the file, exported the Test2 database.xml, and renamed that too. Examining that, found a few headers and no real content - as expected.

Tried to import Test2 database.xml. "Import" button would not even enable, which is appropriate since the file essentially has no content.
Saved Test2 even though nothing had actually changed. Filename suffix changed to osbk.
Post an answer Top  
Answer n° 4
--------
03/10/2022 16:40
by favdb

favdb



You have to know that the file "mv.db" is the temporary working file. The real file, once saved, is an "osbk" file, which is actually a compressed SQL transaction file.

The database export is justified for future use, especially for migration to a version 6, not really for importing... although this is also being considered.
Post an answer Top  
Answer n° 5
--------
05/10/2022 02:30
by donedwards2

donedwards2



Hey, if you tried to send me an email about joining a developer group somewhere, look up user "donedwards" (without the 2) and send it to that address. (Which I'd rather not post even on this somewhat obscure public forum.)
And if you can spot why I couldn't log on to that account even after going through the lost-password process, and had to set up this second account with a disposable email address...
Post an answer Top  
Answer n° 6
--------
05/10/2022 10:48
by favdb

favdb



I sent you an email and added you to the mailing list. I hope it works properly.
Post an answer Top  
active topic active   closed topic closed   Important! Important!   New New message
Correct Correct message   Close Close topic   Make sticky Make sticky  
Forum Topic  Forum 



You are here :   Home » Forum » General discussion » Misc minor bugs
 
 
 
Webmaster - Infos
Preferences

Connect again :
Your user name :
Your password